1#
2# CDDL HEADER START
3#
4# The contents of this file are subject to the terms of the
5# Common Development and Distribution License (the "License").
6# You may not use this file except in compliance with the License.
7#
8# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
9# or http://www.opensolaris.org/os/licensing.
10# See the License for the specific language governing permissions
11# and limitations under the License.
12#
13# When distributing Covered Code, include this CDDL HEADER in each
14# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
15# If applicable, add the following below this CDDL HEADER, with the
16# fields enclosed by brackets "[]" replaced with your own identifying
17# information: Portions Copyright [yyyy] [name of copyright owner]
18#
19# CDDL HEADER END
20#
21
22#
23# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
24# Copyright 2019 OmniOS Community Edition (OmniOSce) Association.
25#
26
27set name=pkg.fmri value=pkg:/system/zones@$(PKGVERS)
28set name=pkg.summary value="Solaris Zones"
29set name=pkg.description value="Solaris Zones Configuration and Administration"
30set name=info.classification value=org.opensolaris.category.2008:System/Core
31set name=variant.arch value=$(ARCH)
32dir  path=etc group=sys variant.opensolaris.zone=global
33dir  path=etc/brand group=sys variant.opensolaris.zone=global
34dir  path=etc/zones group=sys variant.opensolaris.zone=global
35file path=etc/zones/SUNWblank.xml mode=0444 variant.opensolaris.zone=global
36#
37# The SUNWdefault.xml file is marked as non-dehydratable so that is not removed
38# from an IPS image when `pkg dehydrate` is run on it.
39# This file must be retained so that `zoneadm` can determine the default brand
40# for the IPS image during subsequent rehydration.
41#
42file path=etc/zones/SUNWdefault.xml mode=0444 dehydrate=false \
43    variant.opensolaris.zone=global
44file path=etc/zones/index group=sys original_name=SUNWzone:etc/zones/index \
45    preserve=true variant.opensolaris.zone=global
46dir  path=lib variant.opensolaris.zone=global
47dir  path=lib/svc variant.opensolaris.zone=global
48dir  path=lib/svc/manifest group=sys variant.opensolaris.zone=global
49dir  path=lib/svc/manifest/system group=sys variant.opensolaris.zone=global
50file path=lib/svc/manifest/system/resource-mgmt.xml group=sys mode=0444 \
51    variant.opensolaris.zone=global
52file path=lib/svc/manifest/system/zones.xml group=sys mode=0444 \
53    variant.opensolaris.zone=global
54file path=lib/svc/manifest/system/zonestat.xml group=sys mode=0444 \
55    variant.opensolaris.zone=global
56dir  path=lib/svc/method variant.opensolaris.zone=global
57file path=lib/svc/method/svc-resource-mgmt mode=0555 \
58    variant.opensolaris.zone=global
59file path=lib/svc/method/svc-zones mode=0555 variant.opensolaris.zone=global
60file path=lib/svc/method/svc-zonestat mode=0555 variant.opensolaris.zone=global
61dir  path=usr group=sys
62dir  path=usr/bin
63link path=usr/bin/zonename target=../../sbin/zonename
64file path=usr/bin/zonestat mode=0555
65dir  path=usr/kernel group=sys
66dir  path=usr/kernel/drv group=sys
67dir  path=usr/kernel/drv/$(ARCH64) group=sys
68file path=usr/kernel/drv/$(ARCH64)/zcons group=sys
69dir  path=usr/lib
70dir  path=usr/lib/$(ARCH64)
71file path=usr/lib/$(ARCH64)/libbrand.so.1
72file path=usr/lib/$(ARCH64)/libzonecfg.so.1
73file path=usr/lib/$(ARCH64)/libzonestat.so.1
74dir  path=usr/lib/brand
75dir  path=usr/lib/brand/ipkg group=bin
76file path=usr/lib/brand/ipkg/config.xml mode=0444
77file path=usr/lib/brand/ipkg/platform.xml mode=0444
78dir  path=usr/lib/brand/shared group=sys
79file path=usr/lib/brand/shared/common.ksh mode=0444
80file path=usr/lib/brand/shared/query mode=0755
81file path=usr/lib/brand/shared/uninstall.ksh mode=0444
82file path=usr/lib/libbrand.so.1
83file path=usr/lib/libzonecfg.so.1
84file path=usr/lib/libzonestat.so.1
85dir  path=usr/lib/zones
86file path=usr/lib/zones/zoneadmd mode=0555
87file path=usr/lib/zones/zonestatd mode=0555 variant.opensolaris.zone=global
88dir  path=usr/sbin
89file path=usr/sbin/zlogin mode=0555
90file path=usr/sbin/zoneadm mode=0555
91file path=usr/sbin/zonecfg mode=0555
92dir  path=usr/share
93dir  path=usr/share/lib
94dir  path=usr/share/lib/xml group=sys
95dir  path=usr/share/lib/xml/dtd group=sys
96file path=usr/share/lib/xml/dtd/brand.dtd.1 mode=0644
97file path=usr/share/lib/xml/dtd/zone_platform.dtd.1 mode=0644
98file path=usr/share/lib/xml/dtd/zonecfg.dtd.1
99dir  path=usr/share/man
100dir  path=usr/share/man/man1
101file path=usr/share/man/man1/zlogin.1
102file path=usr/share/man/man1/zonestat.1
103dir  path=usr/share/man/man4d
104file path=usr/share/man/man4d/zcons.4d
105dir  path=usr/share/man/man7
106file path=usr/share/man/man7/brands.7
107file path=usr/share/man/man7/zones.7
108dir  path=usr/share/man/man8
109file path=usr/share/man/man8/zoneadm.8
110file path=usr/share/man/man8/zoneadmd.8
111file path=usr/share/man/man8/zonecfg.8
112file path=usr/share/man/man8/zonestatd.8
113driver name=zcons
114legacy pkg=SUNWzoner desc="Solaris Zones Configuration Files" \
115    name="Solaris Zones (Root)"
116legacy pkg=SUNWzoneu desc="Solaris Zones Configuration and Administration" \
117    name="Solaris Zones (Usr)"
118license cr_Sun license=cr_Sun
119license lic_CDDL license=lic_CDDL
120