1#
2# CDDL HEADER START
3#
4# The contents of this file are subject to the terms of the
5# Common Development and Distribution License (the "License").
6# You may not use this file except in compliance with the License.
7#
8# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
9# or http://www.opensolaris.org/os/licensing.
10# See the License for the specific language governing permissions
11# and limitations under the License.
12#
13# When distributing Covered Code, include this CDDL HEADER in each
14# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
15# If applicable, add the following below this CDDL HEADER, with the
16# fields enclosed by brackets "[]" replaced with your own identifying
17# information: Portions Copyright [yyyy] [name of copyright owner]
18#
19# CDDL HEADER END
20#
21
22#
23# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
24#
25
26set name=pkg.fmri value=pkg:/system/scheduler/fss@$(PKGVERS)
27set name=pkg.summary value="Fair Share Scheduler"
28set name=pkg.description value="core software for the fair share scheduler"
29set name=info.classification value=org.opensolaris.category.2008:System/Core
30set name=variant.arch value=$(ARCH)
31dir  path=usr group=sys
32dir  path=usr/kernel group=sys
33dir  path=usr/kernel/sched group=sys
34dir  path=usr/kernel/sched/$(ARCH64) group=sys
35file path=usr/kernel/sched/$(ARCH64)/FSS group=sys mode=0755
36dir  path=usr/lib
37dir  path=usr/lib/class
38dir  path=usr/lib/class/FSS
39file path=usr/lib/class/FSS/FSSdispadmin mode=0555
40file path=usr/lib/class/FSS/FSSpriocntl mode=0555
41dir  path=usr/share/man
42dir  path=usr/share/man/man4
43file path=usr/share/man/man4/FSS.4
44legacy pkg=SUNWfss desc="core software for the fair share scheduler" \
45    name="Fair Share Scheduler"
46license cr_Sun license=cr_Sun
47license lic_CDDL license=lic_CDDL
48